It is currently Thu Aug 22, 2019 12:23 pm


Game extremly slow on OpenSuse 12.1 with ATi card

Anomaly Warzone Earth - all that relates to our game and Linux. Technicall support for Linux - if possible, that is.

Game extremly slow on OpenSuse 12.1 with ATi card

Postby failed_noose » Fri Feb 10, 2012 4:28 pm

Hello,

I'm trying to run Anomaly on my HP laptop with Intel Core 2 Duo, 2 GB of RAM and ATi HD2600 Mobility Radeon running OpenSuse 12.1. I can run the game, but the picture is choppy, has errors from time to time and the main menu and the game are horrifically slow. I've installed the newest graphics card drivers, which didn't help. I've got the game up and running on my desktop, which has Intel Core 2 Quad, 4GB of RAM and an nVIDIA graphics card, so my guess would be ATi driver issues. Anybody got any idea on how to fix this?
failed_noose
 
Posts: 1
Joined: Fri Feb 10, 2012 4:15 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby admin » Mon Feb 13, 2012 10:36 am

Hi,
Please try to re-install the driver.
admin
Site Admin
 
Posts: 504
Joined: Thu Mar 31, 2011 7:28 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby Fredo » Thu Apr 26, 2012 5:18 pm

I can confirm this on Ubuntu 12.04 x86_64. I have an AMD Radeon HD 6320, the driver is fglrx 8.960.

I really looked forwards to playing this game, but currently it is unplayable on my machine.

Do you need any additional information?

Thanks
Fredo
Fredo
 
Posts: 3
Joined: Thu Apr 26, 2012 5:06 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby admin » Fri Apr 27, 2012 10:24 am

Hi,
There are different drivers available around the net and some of them are not helping to run games...
Please try to use the driver from the official ATI site. As far as I remember that one solves the problem.
thx
admin
Site Admin
 
Posts: 504
Joined: Thu Mar 31, 2011 7:28 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby Fredo » Fri Apr 27, 2012 10:42 pm

I did not install some random driver from the net, I am running Ubuntu 12.04’s fglrx, which is the official AMD driver shipped with Ubuntu.

I am not having any issues with any other games. So before I go and manually install the AMD driver, which requires some real effort, I’d like to know if you really think this helps or if this is just guessing.
Fredo
 
Posts: 3
Joined: Thu Apr 26, 2012 5:06 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby admin » Mon May 07, 2012 3:04 pm

That's exactly the issue.
The driver shipped with Ubuntu is not working well.
The one from the official website - does work ok.
thx
admin
Site Admin
 
Posts: 504
Joined: Thu Mar 31, 2011 7:28 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby Fredo » Mon May 07, 2012 6:10 pm

Okay, I did not really expect there to be a difference, since even the Ubuntu drivers contain the AMD binary.

I had to install an AMD driver anyway, and tested it again. The menu still is very sluggish, I’d expect something simple as this to behave more responsive. But the game itself is playable, and I guess that’s the main thing.

Thanks
Fredo
Fredo
 
Posts: 3
Joined: Thu Apr 26, 2012 5:06 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby yorik » Sun May 27, 2012 8:36 pm

Hi there,

Same problem here (debian squeeze 64bit notebook with nvidia 8400m, nvidia driver 295.49, which should be recent enough, less than 1 month old, other games run perfectly).

The game starts, but the main menu as well as the game runs at less than 1 FPS... If I go to the options screen, put resolution to 50% and GFX to low, the black and white scene behind the menu then runs at a good speed, but inside the game it continues at about 1 FPS, no matter if I change again the resolution and GFX settings.

If I restart the game, then the black and white scene behind the main menu runs slow again, even with 50% resolution and low GFX. Changing resolution to any other value the restores good speed, like if something was done when you press the "apply" button that is not done at game startup.

Is it known to run OK on 64bit linux machines? "ldd AnomalyWarzoneEarth" gives normal, usual stuff (correct libGL, only openal and C libs statically linked). I don't know what I can try, I would be glad to help debugging this further, if you guys can advise me!

Looks like an awesome game, thanks and congrats for putting it on linux!
yorik
 
Posts: 4
Joined: Sun May 27, 2012 5:42 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby admin » Mon May 28, 2012 3:22 pm

Hi,

Is it a driver shipped along with the computer?
thx
admin
Site Admin
 
Posts: 504
Joined: Thu Mar 31, 2011 7:28 pm

Re: Game extremly slow on OpenSuse 12.1 with ATi card

Postby yorik » Tue May 29, 2012 9:30 pm

It is the driver from Debian unstable (which usually is one minor number below the current official nvidia release). If you think that trying another driver could help, I can do that, but it seems unlikely. In the meantime I'll try the windows version with wine, to see if there's any difference...
yorik
 
Posts: 4
Joined: Sun May 27, 2012 5:42 pm

Next

Return to Anomaly Warzone Earth - all that relates to our game on Linux. Technicall support for Linux.

Who is online

Users browsing this forum: No registered users and 0 guests

cron