Page 1 of 1

Unable to switch language

PostPosted: Sat Apr 16, 2011 1:54 pm
by mensiid
So, just bought this on steam...and the game starts up with everything in a foreign language (Russian?). In Steam I've tried right-click, then "properties" -> "Language" , but it was already on English, I've set it to French then back to English again, no use. Google shows that nobody has run into this issue yet. I'm using Win7 64bit (Traditional Chinese) if that matters..perhaps it's throwing off the language detection, but then again I've never had this problem with other Steam games before. Can anyone help?

Re: Unable to switch language

PostPosted: Sat Apr 16, 2011 6:49 pm
by tunix
You can turn automatic language detection off and override the setting from the game menu. I know it might be tough when you see Russian menu :) Try the following steps:

1. Launch the game and make it to the main menu.

2. Click the 4th button from the top - it's "help & options"

3. Clich the 3rd button from the top - it's "settings"

4. Click the 6th blue arrow button on the right until the menu switches to English language (or other if preferred).

Let me know if it helps.

Re: Unable to switch language

PostPosted: Sun Apr 17, 2011 1:32 pm
by mensiid
it worked!!! thanks for the help, any idea why it defaults to Russian though?

Re: Unable to switch language

PostPosted: Mon Apr 18, 2011 2:18 pm
by tunix
mensiid wrote:it worked!!! thanks for the help, any idea why it defaults to Russian though?


Nope

Re: Unable to switch language

PostPosted: Fri Oct 09, 2015 2:10 pm
by Krzysiek.P
It helped me too :) thanks

Re: Unable to switch language

PostPosted: Thu Dec 10, 2015 8:35 am
by qqwwee1234
I've set it to French then back to English again, no use.
จีคลับคาสิโน