Page 1 of 1

libcurl-gnutls.so.4

PostPosted: Tue Jul 16, 2013 4:17 pm
by nunardas
hello,
i am using arch linux and FunkySmugglers isn't working at all, i have already installed libcurl and if i use this command pacman -Ql curl | grep libcurl it says the lib is installed but the game won't start anyway. I tried to search google and this forum but there are no answers that could help me.
thank you in advance

pacman -Ql curl | grep libcurl:

curl /usr/lib/libcurl.a
curl /usr/lib/libcurl.so
curl /usr/lib/libcurl.so.4
curl /usr/lib/libcurl.so.4.3.0
curl /usr/lib/pkgconfig/libcurl.pc
curl /usr/share/aclocal/libcurl.m4
curl /usr/share/man/man3/libcurl-easy.3.gz
curl /usr/share/man/man3/libcurl-errors.3.gz
curl /usr/share/man/man3/libcurl-multi.3.gz
curl /usr/share/man/man3/libcurl-share.3.gz
curl /usr/share/man/man3/libcurl-tutorial.3.gz
curl /usr/share/man/man3/libcurl.3.gz

Re: libcurl-gnutls.so.4

PostPosted: Thu Jul 18, 2013 10:15 am
by 11bitQA
Hello!

I'm sorry to hear that you are having issues with our game. Unfortunately as of right now we only support one linux distribution which is Ubuntu.

Re: libcurl-gnutls.so.4

PostPosted: Mon Sep 29, 2014 8:06 pm
by Chewi
I hit the same problem on Gentoo. We can build libcurl against gnutls but this is not the default and multiple SSL providers are not possible. This is dead easy for the developers to fix though. Please ensure the game is linked against libcurl and not libcurl-gnutls. I know this works because I was able to work around the problem by symlinking libcurl in place of libcurl-gnutls.

Code: Select all
ln -s /usr/lib32/libcurl.so libcurl-gnutls.so.4


The game then runs fine. You don't even have to set LD_LIBRARY_PATH. You can also work around it by using sed.

Code: Select all
sed -i "s/libcurl-gnutls.so.4/libcurl.so\x00\x00\x00\x00\x00\x00\x00\x00\x00/g" FunkySmugglers


These are nasty workarounds though. Please fix this properly, guys.

Re: libcurl-gnutls.so.4

PostPosted: Wed Oct 01, 2014 1:35 pm
by admin
We're unable to test many distributions, so we're supporting Ubuntu.
Sorry.

Re: libcurl-gnutls.so.4

PostPosted: Sat Feb 21, 2015 5:53 am
by Himansh
This is extremely pleasant and fair post....You shook posting it....Thanks a ton for posting it....!!

Re: libcurl-gnutls.so.4

PostPosted: Mon Dec 19, 2016 4:17 am
by madooeiei
Thanks a ton for posting it....!!
ทางเข้าจีคลับ