Page 1 of 1

version `GLIBC_2.12' not found (required by ./AnomalyWarzone

PostPosted: Sun Aug 26, 2012 9:13 am
by codygman
Saw this error, was looking at upgrading.... but would make system unstable. I'm running debian squeeze. I tired this after googling for solutions:

You can get around this on debian squeeze via grabbing a testing or unstable version..

Code: Select all
ftp://ftp.debian.org/debian/pool/main/e ... 6_i386.deb

So that it wont mess with the system extract it to the Anomaly dir, optionally create a tmp dir within Anomaly.

$ dpkg -x /path/to/libc6_2.13-26_i386.deb .

Then create a link to it from within the Anomaly dir.

$ ln -s tmp/lib/i386-linux-gnu/libpthread-2.13.so libpthread.so.0

This will get you past the dependency problem but hit you with the segfault.


On my system, the equivalent symbolic link was:

$ ln -s ~/home/cody/Downloads/debs/anomaly/x86_64-linux-gnu/libpthread-2.13.so /opt/Anomaly/libpthread.so.0

After this it still gave me the message about glibc2.12.

Help?

Thanks,

Cody

Re: version `GLIBC_2.12' not found (required by ./AnomalyWar

PostPosted: Sun Aug 26, 2012 9:26 am
by codygman
Just did this:

export LD_LIBRARY_PATH=/home/cody/Downloads/debs/anomaly/lib/x86_64-linux-gnu/

Now tried to start anomaly and got segfault because, of course, the rest of my system doesn't work with glibc_2.13 :/

Re: version `GLIBC_2.12' not found (required by ./AnomalyWar

PostPosted: Tue Sep 08, 2015 9:47 am
by serizawa1234
You can get around this on debian squeeze via grabbing a testing or unstable version..
ดาวน์โหลด จีคลับ