It is currently Tue Jul 17, 2018 4:53 am


Game does not start in Ubuntu (Intel GPU issues)

Anomaly Warzone Earth - all that relates to our game and Linux. Technicall support for Linux - if possible, that is.

Re: Game won't start (Linux)

Postby mklj » Wed Feb 01, 2012 7:50 pm

Same here, the game segfaults right after start:

Code: Select all
GLX_EXT_swap_control not supported, unable to set vertical sync.
OpenAL sound device name: ALSA Default
Segmentation fault


Computer specs:

Linux darkstar 2.6.39.4 #2 SMP Wed Nov 30 09:08:11 CET 2011 i686 Genuine Intel(R) CPU T2300 @ 1.66GHz GenuineIntel GNU/Linux

Thinkpad T60 ( Lenovo ) , R300, 2.5 GB RAM, running on slackware.

What is weird, that 3 times I managed to get game running, two times it segfaulted right after intro movie and one time I was able to get to the menu.
dmesg:

Code: Select all
[ 6887.176503] Renderer[31482]: segfault at a0c2f80 ip 0811833d sp b4efe670 error 4 in AnomalyWarzoneEarth[8048000+284000]
[ 6889.714229] Renderer[31489]: segfault at 9aa0c50 ip 0811833d sp b4efe670 error 4 in AnomalyWarzoneEarth[8048000+284000]
[ 6905.268966] Renderer[31501]: segfault at aefc1440 ip 0811833d sp b5007670 error 4 in AnomalyWarzoneEarth[8048000+284000]
[ 7978.825684] Renderer[31738]: segfault at b5989f00 ip b74590e4 sp b4efe5fc error 7 in libc-2.13.so[b73de000+15c000]
mklj
 
Posts: 1
Joined: Wed Feb 01, 2012 7:46 pm

Re: Game does not start in Ubuntu

Postby julian_fern » Thu Feb 02, 2012 12:22 am

I just got the game from Humble Bundle and it won't work :/

Here is what terminal tells me:
Code: Select all
GLX_EXT_swap_control not supported, unable to set vertical sync.
Extension EXT_texture_compression_s3tc not supported. Shutting down the game.


I see the issue is already reported, but are you guys gonna do anything about it?
Cause i only got this humble bundle for this game, really :/

If i use the drivers from xorg-edgers, it would work?
I have a Intel HD 3000 Sandy Bridge graphic card btw.
julian_fern
 
Posts: 1
Joined: Thu Feb 02, 2012 12:19 am

Re: Game does not start in Ubuntu

Postby solitaire » Thu Feb 02, 2012 1:30 am

I'm getting the same error.
Running Ubuntu 11.10
Graphics : Intel® 965GME/GLE x86/MMX/SSE2
solitaire
 
Posts: 1
Joined: Thu Feb 02, 2012 12:29 am

Re: Crashes X on Kubuntu 11.10

Postby xedi » Thu Feb 02, 2012 3:27 pm

You could look into the ~/.xsession-errors file. That way or another I do not think you will get it to work, because the game does not support the Intel GPU Linux drivers.

viewtopic.php?f=10&t=192&sid=ff7fca738227e79f7f465f2ed9add910#p781
xedi
 
Posts: 4
Joined: Tue Jan 31, 2012 10:05 pm

Re: Game does not start in Ubuntu

Postby flabbergastedpickle » Thu Feb 02, 2012 7:34 pm

Same over here... Ubuntu 11.10 running Unity (default) 3D desktop 64-bit Sandy Bridge Intel HD 3000. Segfault with exactly same messages (except that I have s3tc libs installed so I don't get any of the s3tc errors). No debug symbols so not much info on that end. The screen momentarily flickers and that is that.

Since there is an android version of this which I doubt uses s3tc (can Android even support that?), it would be nice for the game to have a fallback on s3tc-free implementation as is the case with a number of other Humble Bundle titles who did this after the initial release (e.g. Cogs, Braid, etc.). Intel HD 3000 is plenty powerful and does quite well in the shaders department as well (see Marble Arena 2 which has very cool selection of shaders running concurrently) and while I used to be exclusively a dedicated GPU user (AMD/Nvidia), most recently I've gone the Intel route simply because of its open-source architecture and reliable support of core laptop functionality (e.g. suspend/hibernate).

Devs, please fix this! I have tried the game on my Android phone and it rocks but will wait until a native Linux version gets fixed as that is where I would really like to play this...
flabbergastedpickle
 
Posts: 2
Joined: Thu Feb 02, 2012 7:24 pm

Re: Game does not start in Ubuntu

Postby admin » Fri Feb 03, 2012 4:09 pm

Hi,
(merged the threads all related to Intel GPU issues)

The game requires Nvidia or Ati cards, same as Windows or Mac version of the game. On Intel graphic cards the driver errors make it impossible to use many advanced rendering techniques that are utilized in Anomaly Warzone Earth.
But we missed that so now we're looking at this issue and trying to find out if there is any chance to make it live on Intel cards.
Thanks,

EDIT - we just got this from Brazilian LoCoTeam:
https://launchpad.net/~oibaf/+archive/graphics-drivers
The guys we'll try to check it out. We'll try that too. Stay tuned.
admin
Site Admin
 
Posts: 504
Joined: Thu Mar 31, 2011 7:28 pm

Re: Game does not start in Ubuntu

Postby flabbergastedpickle » Fri Feb 03, 2012 11:11 pm

Are you suggesting that we try out the new ppa drivers? Is there indication that they may fix the said problems? If so, I'll gladly do so and report back.

As for supporting Intel cards, couldn't you simply use the rendering path used on Android devices as I seriously doubt they do anything more advanced than what an intel card can do. If so, it would be nice to see that as a fallback way of rendering the game even if that meant simpler visuals... Just a thought...

EDIT: I tried the said drivers. On Sandy Bridge Intel anomaly now kills the entire Xorg server and kicks me out to the login screen. Unsupported sync error is still displayed but I have no idea what else might be displayed since the Xorg goes down before anything else is printed out.
Last edited by flabbergastedpickle on Wed Feb 08, 2012 10:22 pm, edited 1 time in total.
flabbergastedpickle
 
Posts: 2
Joined: Thu Feb 02, 2012 7:24 pm

Won't start in Ubuntu 10.10

Postby skyewm » Sat Feb 04, 2012 6:04 am

With an Intel i915 chipset and using both the xorg-edgers PPA and xorg-stable PPA.

https://launchpad.net/~xorg-edgers/+archive/ppa

Code: Select all
$ anomaly
GLX_EXT_swap_control not supported, unable to set vertical sync.
Extension EXT_framebuffer_sRGB not supported. Shutting down the game.


glxinfo shows that I do indeed have the EXT_framebuffer_sRGB extension. (only when using the xorg-edgers PPA, as the extension was only added in a version of mesa more recent than Ubuntu 10.10). ~/.xsession-errors has no additional information from running anomaly.

I installed the x86_64 deb but it looks like this binary and the libraries it links against are all 32-bit.

Code: Select all
skyewm@purble:/opt/Anomaly$ ldd ./AnomalyWarzoneEarth
   linux-gate.so.1 =>  (0xf7783000)
   libX11.so.6 => /usr/lib32/libX11.so.6 (0xf763f000)
   libGL.so.1 => /usr/lib32/mesa/libGL.so.1 (0xf75ec000)
   libopenal.so.1 => /opt/Anomaly/./libopenal.so.1 (0xf7576000)
   libstdc++.so.6 => /opt/Anomaly/./libstdc++.so.6 (0xf748b000)
   libm.so.6 => /lib32/libm.so.6 (0xf7465000)
   libgcc_s.so.1 => /opt/Anomaly/./libgcc_s.so.1 (0xf7449000)
   libc.so.6 => /lib32/libc.so.6 (0xf72ee000)
   libpthread.so.0 => /lib32/libpthread.so.0 (0xf72d5000)
   librt.so.1 => /lib32/librt.so.1 (0xf72cb000)
   libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf72b1000)
   libdl.so.2 => /lib32/libdl.so.2 (0xf72ad000)
   libXext.so.6 => /usr/lib32/libXext.so.6 (0xf729d000)
   libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf7299000)
   libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf7292000)
   libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf728c000)
   libdrm.so.2 => /lib32/libdrm.so.2 (0xf7282000)
   /lib/ld-linux.so.2 (0xf7784000)
   libXau.so.6 => /usr/lib32/libXau.so.6 (0xf727e000)
   libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7278000)


Any ideas?
skyewm
 
Posts: 1
Joined: Sat Feb 04, 2012 5:53 am

Re: Game does not start in Ubuntu (Intel GPU issues)

Postby NullNix » Sun Feb 05, 2012 11:33 pm

I can confirm this -- *not* in Ubuntu but in a linux-from-scratch installation, running x11-xserver 1.10.3.901, mesa 7.11 (Gallium), and version 6.14.2 of the open source ATI drivers, with kernel 3.2.4, Radeon KMS, two monitors using XRandR and s3tc support enabled (phew, could there be any more variables in Linux video support?). I've got a Radeon HD 4870, and I'm using PulseAudio 1.1 (using the ALSA PulseAudio plugin to route absolutely all sound through PA).

... and I see:

% anomaly
GLX_EXT_swap_control not supported, unable to set vertical sync.
OpenAL sound device name: PulseAudio Default
Segmentation fault (core dumped)

The backtrace of course has no symbols, but the executable is not PIE so you may well be able to decode the call stack anyway, since all the addresses appear to be inside the AnomalyWarzoneEarth binary itself, and thus at non-randomized addresses:

Program terminated with signal 11, Segmentation fault.
#0 0x0811833d in ?? ()
(gdb) bt
#0 0x0811833d in ?? ()
#1 0x080d5fc5 in ?? ()
#2 0x080d6cf5 in ?? ()
#3 0x0815a182 in ?? ()
#4 0x0815a6cc in ?? ()
#5 0x080c001f in ?? ()
#6 0x081c7b84 in ?? ()
#7 0x080c15e7 in ?? ()
#8 0x081c7ad8 in ?? ()
#9 0x081c7b2f in ?? ()
#10 0xf72d3cfa in start_thread () from /lib32/libpthread.so.0
#11 0xf73c14fe in clone () from /lib32/libc.so.6
NullNix
 
Posts: 1
Joined: Sun Feb 05, 2012 11:22 pm

Re: Game does not start in Ubuntu (Intel GPU issues)

Postby kedster » Fri Feb 10, 2012 4:39 am

I also receive the same error, i would really love to play this game on my Computer, it is an amazing game.
I have an intell i5 2410 intel hd 3000 i beleive


ketterer@ketterer-ubuntubook:~$ anomaly --optimal
GLX_EXT_swap_control not supported, unable to set vertical sync.
Extension EXT_texture_compression_s3tc not supported. Shutting down the game.
ketterer@ketterer-ubuntubook:~$
kedster
 
Posts: 1
Joined: Fri Feb 10, 2012 4:03 am

PreviousNext

Return to Anomaly Warzone Earth - all that relates to our game on Linux. Technicall support for Linux.

Who is online

Users browsing this forum: No registered users and 1 guest

cron